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Hardware-Programmierung

Heutiger Stand der Technik fiir den Entwurf digitaler Schaltungen ist
die Beschreibung der Zielfunktion in einer
Hardware-Beschreibungssprache. Simulation auf dem Rechner.
Prototyp-Fertigung mit programmierbaren Logikschaltkreisen (FPGA
Field Programmable Gate Array). FPGAs bestehen aus
m programmierbaren Logikblocken,
m programmierbaren EA-Schaltungen,
m einem programmierbaren Verbindungsnetzwerk und
m optional weiteren konfigurierbaren Schaltungsblocken, z.B.
Blockspeichern, Multiplizierern, Taktversorgung und
Prozessorkernen.
Programmierung 3hnlich wie bei Mikrorechnern iiber eine serielle
Programmierschnittstelle (JTAG, ISP,...). Programmierdauer wenige
Minuten.
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Prototyp-Plattform fiir die Laboriibungen

% programmierbares

Verbindungsnetzwerk oty
. . PLB | programmierbarer
programmierbare Einga- ;i
IOr be-Ausgabe-Schaltung %, Logikblock
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Das verwendete

m einen programmierbaren Schaltkreis fiir Schaltungen, die mit
normalen Schaltkreisen bis zu 106 Gatter umfassen kdnnen,
m 100MHz Quarztakt, 8 Leuchtdioden, 4 7-Segment-Anzeigen,
m 8 Schalter, 5 Taster, 1IMB SRAM,
m Anschliisse fiir USB-Tastatur / -Mouse, USB-UART und VGA.
Ausreichend fiir alles, was im Studium vermittelbar ist.
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1. Einfache Gatterschaltung

Einfache Gatterschaltung
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1. Einfache Gatterschaltung

Einprogrammieren von Logikfunktionen

Schalter programmierbarer Schaltkreis — Leuchtdioden
SWO0 LDO
SW1
SW2 LD1
SW3
SW4 LD2
SW5
SW6 LD3
SW7

Im ersten Beispiel sollen vier Gatter so einprogrammiert werden, dass
die Eingdnge von Schaltern steuer- und die Ausgdnge mit LEDs
beobachtbar sind. Die Kastchen mit » T10« etc. sind die Bezeichner
der Schaltkreisanschliisse, an denen die Schalter und LEDs auf der

Baugruppe angeschlossen sind.
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1. Einfache Gatterschaltung
Eine VHDL-Beschreibung besteht aus Schnittstellenbeschreibung:

entity Logikrechner is
port (SWO, SWi, SW2, SW3, SW4, SW5, SW6, SWT7:
in std_logic;
LDO, LD1, LD2, LD3: out std_logic);
end Logikrechner;

und einer Beschreibung der Realisierung

architecture Behavioral of Logikrechner is
begin

LDO <= SWO and SWi; 00 I I— LD
s
LD1 <= SW2 nand SW3; SW2
LD2 <= SW4 or  SW5; s P LD1
LD3 <= SW6 xor SW7; W —* .
end Behavioral; SW5
Die Schnittstelle definiert die :X]Vﬁ LD3
. . . 7
Anschliisse (Bezeichner, Richtung,
Datentyp. Die Realisierung beschreibt die Schaltung.
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1. Einfache Gatterschaltung
Entwurfsvorbereitung

m Zip-Datei EDS GU2.zip von der Web-Seite laden
und entpacken.

m Mit dem Web-Browser diesen Foliensatz &ffnen.

m »Xilinx ISE« &ffnen:

Start > All Programs > Xilinx Design Tools >
ISE Design Suite 14.6 > ISE Design Tools >
64-bit-Project Navigator
m Fenster »What's New ...« und »Tip of
the Day« schlieRen.
m (Project Navigator) File > Open Project > <entpacktes Archiv>
> Logikrechner > Logikrechner.xise auswahlen.
m (Hierarchie-Fenster) .../Logikrechner.vhd auswahlen, mit
Doppelklick 6ffnen. Schaltungsbeschreibung kontrollieren.
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1. Einfache Gatterschaltung

Editier- und Werkzeugansicht

View: @) IFji[Implememaﬁon @ 4 —
. 5 library IEEE;
Hleramhy & use IEEE.S5TD LOGIC 1164.ALL;
e 'Eéj Logikrechner 7 - -
BE‘E xcbshdb-3csg324 g8 entity Logikrechner is
B"ggﬁﬂ Legikrechner - Behavieral (L - 8 Port ( SWO, SW1, SW2, SW3, SW4, SWS,
11 i | A [} SWe, SW7 : in STD LOGIC;
11 LDO, LD1, LD2, LD3 : out STD LOGIC):
Processes: Logikrechner - Behavioral 12 end Logikrechner;
; Design Summary/Reports 13
Design Utilities 14 architecture Behav. of Logikrechner is
User Constraints 15 begin
Synthesize - X5T 1g LDO <= 5WO0 and 5W1:
Implement Design 17 LD1 <= 5WZ nand 5W3;
Generate Programming File 18 LD2 <= SW4 or SWS;
Configure Target Device 13 LD3 <= SW& =x=or SWT:

Analyze Design Using ChipScope 20 end Behavioral;

Fenster unten links zeigt die fiir das Entwurfsobjekt » Logikrechner«
verfiigbaren Bearbeitungswerkzeuge.
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1. Einfache Gatterschaltung

Die Constraints-Datei

Doppelklick auf »Logikrechner.ucf«:

Design + 08 X|| 1 HET Loc = Ti0:
view: @ f&} Implementation ) [ Simulation 2 NET Loc = Ts;
i h 3 NET LOC = V9
\erarchy 4 NET LOC = ME;
'C‘ﬂ Legikrechner 5 NET LOC = N&g;

= £d xcbshdB-3csg324 & NET LOC = US&;
= ;ﬁ; Legikrechner - Behavieral (Logi 7 NET LoC = VE&;
E Logikrechnerucf & NET LOC = T5;

4 1n | § 9 NET LOoC = Ule:;
10 NET LoC = Vie;

Processes: Logikrechnerucf 11 NET LOC = T15;
% User Constraints 1z NET Loc = V13

Die Constraints-Datei enthalt alle zusatzlichen Informationen zur
Vorgabe der Zielfunktion, die nicht in der VHDL-Datei stehen: die
Pin-Namen der Schaltungsanschliissen (s.o.), Taktfrequenz, ...
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1. Einfache Gatterschaltung

Ubersetzen, Programmieren und Ausprobieren

m (Hierarchy-Fenster) .../Logikrechner.vhd auswéhlen. (Processes)
mit Doppelklick auf » Generate Programming File« (Synthese,
Platzierung, Verdrahtung, ...).

m »Configure Target Device ...« aufklappen

m (Processes) Doppelklick auf » Manage Configuration Project
(iIMPACT)«

m (iMPACT) Doppelklick auf »Boundary Scan«

m (Boundary Scan) Rechtsklick auf (Right click ...) > »Initialize
Chain«. »Auto Assign ...« Yes.

m Fiir »xcbslx16« »logikrechner.bit« im Verzeichnis
»Logikrechner« auswahlen; »Open«.

m »Attache SPI...« »No«. Nichstes Fenster » OK«.

m Rechtsklick auf den Chip »xcbslx16« > »Program«.

m Ausprobieren: Schaltereinstellungen vornehmen und
LED-Anzeige kontrollieren.
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1. Einfache Gatterschaltung

Das Syntheseergebnis: »Synthesize - XST > View Technology
Schematic«; Start with a schematic of a top-level block > OK >

Doppelklick Blackbox: Logikrechner:1
lut2
ibuf obuf
swi i D o 1 o i [“x: o LDo
SW1_IBUF < LDO_OBUF
LDO1
ibuf
SWO e o lut2
L obuf
SWO_IBUF p T 1=
L
LD1_OBUF
LD
lut2
Sw3|
obuf
SW3_IBUF . o i o |D2
) L
: LD2_OBUF
LD21

Prof. G. Kemnitz, Dr. C. Giesemann - Institut fiir Informatik, Technische Universitidt Clausthall3. April :12/33



1. Einfache Gatterschaltunge

Das Ergebnis der Platzierung und Verdrahtung: »Implement Design
> Map > Manually Place & Route (FPGA Editor)«.

D2_OBUF", site "SLIC]
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HKW 1. Einfache Gatterschaltung

Schaltung in dem rot hervorgehobenen Slice:

[ SRIMTD
1 SRIMm
SR

LUT (Tabellen-
funltion) realisiert
als programmierter
RAM mit 6 Ein- und o UOFF
zwel Ausgangen [JL&TCH
CF JanDaL
[CK [JoRaL

[ sRIMTD

SE‘ SRINITI

. Kemnitz, Dr



2. Simulation

Simulation
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2. Simulation

Vorbemerkungen zur Simulation®

Die Simulation benétigt ein Testobjekt. Das sei hier die nachfolgende
Zshlfunktion:

entity Incrementd4Bit is
Port ( x ¢ in =td 1
¥ 1 oout std 1

end Increment4Bit;

{3 downto 0);
vector (3 downto 0));

architecture Behavioral of Increment4Bit is=
begin
¥ <= =td_logic vector (unsigned(x) + 1):
end Behavioral:
Zusatzlich wird ein Testrahmen zur Erzeugung der Eingabesignale
bendtigt. Das ist eine Entwurfseinheit mit dem Testobjekt als
Teilschaltung und einem Prozess zur Erzeugung der Eingaben.

'Die schrittweise Beschreibung, was zu tun ist, folgt ab Folie 19.

Prof. G. Kemnitz, Dr. C. Giesemann - Institut fiir Informatik, Technische Univers

Clausthall3. April

116/33



Prof. G. Kemnitz, Dr. C. Giesemann -

2. Simulation

LIBRARY ieee;
USE ieee.std_logic_1164.ALL;
USE ieee.numeric std.ALL;
ENTITY IncTE IS
END IncTB:
ARCHITECTURE behawvior OF IncTB IS
SIGHNAL x : =td logic wector(3 downto 0) =
SIGHNAL vy : =td logic wector(3 downto 0);
BEGIN
—— Instantiate the Unit Under Test (UUT)
uut: entity work.Increment4Bit PORT MAP |
X =» X,
v =y
)i
—— Stimulus process
stim proc: process
begin
for i in 1 to 20 loop
wait for 10 ns;
® <= =td logic vector(unsigned(x) + 1):
end loop:
wait;
end process;
END;

(others =»

"0
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Simulationsarten

m Simulation des Verhaltens ohne Verzgerungen:

Value | [

m Simulation der synthetisierten und verdrahteten Schaltung (mit
Verzégerungen)
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2. Simulation

Arbeitsschritte

Anlegen eines neuen Projekts:
m (ISE) »File > New Project«.
m Name »Increment4Bit« > Next .
m Einstellungen bleiben wie im Bild gezeigt > Next > Finish:

Property Mame E‘uralue
Product Cateqory All |Z|
Family Spartani |Z|
Device XCASLA16 []
Package 56324 []
Speed -3 |Z|
Top-Level Source Type HOL

Synthesis Tool XST (VHDL Verilog) E
Simulator 1Sim (VHDL/Verilog) [+
Preferred Language VYHDL E
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2. Simulation

Simulation [ | View: © {8} Implementation @ f3E Simulation

Behavioral E

Hierarchy

vorbereiten

B

=] IncrernentdBit
= B xcOshdf-3csg324
&= [ IncTB - behavior (IncTE.vhd)
uut - Incrementd4Bit - Behavioral (IncrementdBit

fu
£ 5]

=

P2 Mo Processes Running

| W

Processes: IncTB - behavior

=% (I8im Simulator
P2  Behavioral Check Syntax
) Simulate Behavioral Model

£1 £1

LI

Mit »Project > New Source« ein »VHDL Module«
»Increment4Bit.vhd« und eine »VHDL Test Bench« »IncTB.vhd«
hinzufiigen und die Beschreibungen von den Folien zuvor eintippen.
Von Implementation auf Simulation umstellen. Nach der Eingabe fiir
beide Dateien »Behavioral Check Syntax« und Fehlerbeseitigung.
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2. Simulation

Simulation ohne Verzogerung

m »Simulate Behavioral Model«

m Darstellungsbereich mit dem Zoom richtig einstellen.

m Simulator schlieRen, bevor eine neue Simulation aus »ise«
heraus gestartet wird.
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2. Simulation

Post-Place & Route Simulation

m Auf »Implementation« umstellen und »Implement Design«

ausfihren.

m Auf »Simulation« zuriickstellen, Simulationsart auf »Post

Route« umstellen.

m ... Syntax Check.
m »Simulate
Post-Place

& Route Model«.

Prof. G. Kemnitz, Dr. C. Giesemann - Institut fiir Informatik

] | View: Iﬂlmplemeniﬁﬁon o)

o

wilbesitadin

Hierarchy

'E:J Incrementd Bit

= B xcBshdB-3csg324

IncTB - behavior (IncTB.vhd)

P2 Mo Processes Running

EAIENGL

Processes: IncTB - behavior
& ‘ﬁ ISim Simulator
[ Post-Place & Route Check Syntax

Simulate Post-Place & Route Model

, Technische Universitat Clausthall3. April

1 92/33



3. Taktteiler

Taktteiler
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3. Taktteiler

Taktteiler

m Teilen des 100MHz-Eingabetakts durch 232
m Ausgabe der hochstwertigen Zahlerstellen auf Leuchtdioden

LDO

LD1

LD2

Z LD3

+ 39 LD4

LD5
LD6
LD7

V10

GCLKO

m 100/2%* ~ 6 Hz; 100/2%° ~ 3Hz; ...
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3. Taktteiler

Takt- programmierter Schaltkreis Leuchtdioden
eingang
LDO
LD1
LD2
Z LD3
32 LD4
LD5
LD6
GCLKO V10 LD7
GCLKO }
Z0 (1)
21 (1) 1 I 1 I 1 I 1 I
22 (1) B I E— L
Z3 51 I
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3. Taktteiler

entity Taktteiler is
port (GCLKO: in std_logic;
LDO, LD1, ..., LD7: out std_Logic);
end entity;
architecture test of Taktteiler is
signal z: std_logic_vector (31 downto 0);
begin
process (GCLKO)
begin
if rising_edge (GCLKO) then
z <=z + 1;
end if;
end process;
LDO <= z(24);

LDo
LD1
LD2

LD3

LD1 <= z(25); LD4

e LD5

LD7 <= z(31); LD6

end architecture; V10 LD7
GCLKO
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3. Taktteiler

Prof. G.

Erzeugung der Konfigurationsdatei

m (Projektnavigator) File > Open Project > Ebene zuriick >
Taktteiler > Taktteiler.xise.

m (Hierarchy-Fenster) .../ Taktteiler.vhd auswahlen. Mit
Doppelklick 6ffnen (Schaltungsbeschreibung).

m (Hierarchy-Fenster) Taktteiler-Behavioral aufklappen,
.../ Taktteiler.ucf auswidhlen. Mit Doppelklick ffnen
(Constraints).

m (Hierarchy-Fenster) .../ Taktteiler.vhd auswihlen (Processes).

Mit Doppelklick auf » Generate Programming File«
(Abarbeitung: Synthese, Platzierung, Verdrahtung bis
Konfigurationsdaten erzeugen).

Kemnitz, Dr. C. Giesemann - Institut fiir Informatik, Technische Universitidt Claustha
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3. Taktteiler

Programmieren und Ausprobieren

Wenn »Impact« noch gedffnet ist?:

m Rechtsklick auf den Chip »xcbslx16«. »Assign New
Configuration File«.

m »taktteiler.bit« im Verzeichnis » Taktteiler« auswahlen.
»Open«. Attach SPI ... > No.

m Rechtsklick auf den Chip »xcbslx16« > »Program«.

m Ausprobieren.

m Schaltung dndern, z.B. hdherfrequente Takte (niederwertigere)
Zghlerbits ausgeben oder Anschlusszuordnung in der ucf-Datei
dndern.

2y Impact« 6ffnen siehe Folie 11.
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4. Ampelsteuerung

Ampelsteuerung
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4. Ampelsteuerung

Ampelsteuerung
Takt- Zéahler Ausgabetabelle
generator

25

2(29...26)| Autos Fussg.
0000 gelb rot
Z 0001 gelb rot
32 0010 grin rot
0011 griin rot
0100 griin rot

GCLKO V10 o

process (GCLKO)

begin
if rising_edge (GCLKO) then
z <=z + 17, -- Zahler
LD(0) <= z(25); -- Taktausgabe
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4. Ampelsteuerung

25

2(29...26)| Autos Fussg.
0000 gelb rot
Z 0001 gelb rot
39 0010 griin rot
0011 grin rot
0100 griin rot

GCLKO V10 "

case z(29 downto 26) is
when "0000"|"0001"
=> LD(7 downto 3) <= b"010_10"; --4:gelb, F:rot
when "0010"|"OO11"
=> LD(7 downto 3) <= b"001 10"; --A:grin, F:rot
-- ab hter selbst weiterentwickeln
when others
=> LD(7 downto 3) <= b"100_10"; --4A:rot, F:rot
end case;
end if;
end process;
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4. Ampelsteuerung

Erzeugung der Konfigurationsdatei

m (Project Navigator) File > Open Project > Ebene zuriick >
Ampel > Ampel.xise.

m (Hierarchy-Fenster) .../Ampel.vhd auswahlen. Mit Doppelklick
offnen (Schaltungsbeschreibung).

m (Hierarchy-Fenster) Ampel-Behavioral aufklappen, .../Ampel.ucf
auswahlen. Mit Doppelklick 6ffnen (Constraints).

m (Hierarchy-Fenster) .../Ampel.vhd auswédhlen (Processes). Mit
Doppelklick auf » Generate Programming File« (Abarbeitung:
Synthese, Platzierung, Verdrahtung bis Konfigurationsdaten
erzeugen).
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4. Ampelsteuerung

Programmieren und Ausprobieren
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Rechtsklick auf den Chip »xc6slx16«. »Assign New
Configuration File«.

»ampel.bit« im Verzeichnis » Ampel« auswahlen. »Openc;
Attach SPI ... > No.

Rechtsklick auf den Chip »xcb6slx16« > »Program«.
Ausprobieren.

Schaltung dndern, z.B. hoherfrequente Takte (niederwertigere)
Zghlerbits ausgeben oder Anschlusszuordnung in der ucf-Datei
andern.

’ Ausgang ‘ A:griin ‘ A:gelb ‘ A:rot ‘ F:griin ‘ F:rot ‘
| Anschluss | J7 | H3 | GL | L7 | J6 |
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